Interaction between 2 fixtures [fixed]

create scenes for multi-RGB channels fixtures

Interaction between 2 fixtures [fixed]

Postby MortaR » 27 April 2020, 17:25

Good day.

I have added a new LED-pixel-chain to my Sweetlight and control it by pixel. But with a strange phenomenon.

To the facts:

There is a long pixelstripe in Universe 2, this has 120 pixels with 3 channels for RGB, i.e. DMX address 001-360. I have now added the new LED-pixel-chain at the back, this has 50 pixels with 3 channels for RGB, i.e. DMX address 361-510.

Now I have programmed a rainbow in pixels for the new LED-pixel-chain, which works perfectly with red / black and with green / black as seen in the video. But if I change the color to blue or any shade of blue, for some reason the long LED stripe on DMX channels 001-360 comes on briefly in completely red.

I have checked everything for many hours now and find no error in my settings. Universe 1 with all devices does not seem to be affected.

Does anyone have an idea where to start searching for errors?

Here is the short video showing the problem: https://druckluftkammer.de/stuff/sweetlight.mp4
MortaR
 
Posts: 23
Joined: 07 February 2010, 17:50

Re: Problems within pixels

Postby thorehl » 29 April 2020, 09:41

Long strip DMX 1-360
Shorter st. DMX 361-510

I have a feeling your channels are overlapping somewhere. From the looks of it, not in Sweetlight. All though we have not seen mapping addresses.
Thore
lydlys.com - Freelance sound & light engeneer
Using HW: D1024 & D512
Controller: 2x Akai APC mini
thorehl
 
Posts: 194
Joined: 20 January 2015, 22:16

Re: Problems within pixels

Postby MortaR » 30 April 2020, 15:17

Do you mean that with mapping adresses?

The short LED-pixel-Chain is controlled by 2811 chips each LED and behind a controller (https://shop.led-studien.de/de/search?p ... words=lk71). The DMX-adress of that controller is set to 361 and to 50 pixels.

Both, the long stripe and the pixel-chain (short stripe) are doing everything fine with normal steps-scenes yet.

[image]
MortaR
 
Posts: 23
Joined: 07 February 2010, 17:50

Re: Problems within pixels

Postby thorehl » 30 April 2020, 15:32

No, those are the fixture addresses.

Pixel addresses are located here:
Image


Since my pixel bars are 40x1 pixels, the addresses are corrupted on this display, but I guess you understand where to look (Right click > Fixture properties).

But like I said, I don't think the problem is with Sweetlight configuration, but on the physical controller. The addressing there
Thore
lydlys.com - Freelance sound & light engeneer
Using HW: D1024 & D512
Controller: 2x Akai APC mini
thorehl
 
Posts: 194
Joined: 20 January 2015, 22:16

Re: Problems within pixels

Postby MortaR » 30 April 2020, 15:43

I will take a photo tomorrow. Thank you for today.
MortaR
 
Posts: 23
Joined: 07 February 2010, 17:50

Re: Problems within pixels

Postby MortaR » 04 May 2020, 08:02

Ok, I found the problem.

Controller 1 for the long stripe has DMX adress 1 and uses in Sweetlight 001-360 for the 120 pixels
Controller 2 for the short stripe has DMX adress 361 and uses in Sweetlight 361-510 for the 50 pixels

But the channels 510, 511 and 512 are used by controller 1 to make the long stripe full lighten up in red (510), green (511) and blue (512).

So, the channel 510 was double used in my system by the long stripe controller 1 and the short stripe controller 2. I have to say, that I have no idea why controller 1 has these 3 channels always in use.

Thanks for your time.
MortaR
 
Posts: 23
Joined: 07 February 2010, 17:50

Re: Problems within pixels

Postby thorehl » 04 May 2020, 08:21

Good news indeed. Glad you figured it out. Happy lighting :idea:
Thore
lydlys.com - Freelance sound & light engeneer
Using HW: D1024 & D512
Controller: 2x Akai APC mini
thorehl
 
Posts: 194
Joined: 20 January 2015, 22:16


Return to Pixels

Who is online

Users browsing this forum: No registered users and 3 guests