Xpress-100 Windows 10 driver problem

usb to dmx - 100 dmx channels only for Windows (2011 - 2019)

Xpress-100 Windows 10 driver problem

Postby NormanGarland » 05 March 2021, 17:04

Hi Lighting Controller

After spending many hours working on this problem I am convinced the Drivers.zip file (dated May 2018) you make available to download from this site and extract various driver file sets do not work under the latest Windows 10 version V20H2 64-bit, released February 2021.

I have tried installing each version of the 64-bit and 32-bit EFKcable and EFKusb drivers in turn and rebooting the PC on each install but I still get the error message in Driver Status that says:

The drivers for this device are not installed. (code 28)
There are no compatible drivers for this device.
To find a driver for this device, click Update Driver.

On each reboot after trying a different version of EFK driver, the Windows Device Manager displays a yellow ! against the USB Serial Port device name.

Removing the Xpress-100 USB-to-DMX cable from the PC makes the USB Serial Port device disappear from the Device Manager. This clearly indicates the PC is seeing the Xpress-100 when it is plugged into a USB port of the PC.

The latest version of ShowXpress (v9.2.23) is installed on my Windows 10 PC (AMD Athlon II X2 250 Processor 3.00GHz, 6GB RAM).

When the software is launched a ShowXpress Startup window briefly appears that states:

Starting...
default
1 Interface found
Xpress100
0 Artnetuniverse available

This indicates the software is detecting the Xpress-100. If ShowXpress is launched without the Xpress-100 plugged in the Startup window states:

Starting...
default
0 Interface found
0 Artnetuniverse available

The above information convinces me that ShowXpress is able to see the Xpress-100 cable but Windows 10 does not accept any of the EFK drivers you provide.

Are you able to provide a solution to this problem please?

Best regards
Norman Garland
Garland Digital Ltd
UK
NormanGarland
 
Posts: 3
Joined: 13 February 2021, 15:23

Re: Xpress-100 Windows 10 driver problem

Postby support » 05 March 2021, 18:20

Sorry we are not able to reproduce this problem.
We just forced the update to V20H2 64bits to check, and it works here.
Image

Our PC software drives the interface correctly.
The "USB Serial Port" line does not affect the interface operating.
The Lighting Controller
support
Administrateur
 
Posts: 9216
Joined: 07 December 2009, 16:32

Re: Xpress-100 Windows 10 driver problem

Postby NormanGarland » 08 March 2021, 15:39

Thank you for your prompt response.

I checked the Device Manager in this version of Windows 10 and get exactly the same results as you:

There is a ! in a yellow warning triangle after the USB Serial Port device with the message: There are no compatible drivers for this device.
There is a driver: CABLE interface 64bits (2018_04_25) under Universal Serial Bus controllers with the message: This device is working properly.
Very misleading.
However you say "Our PC software drives the interface correctly. The "USB Serial Port" line does not affect the interface operating." so I must believe you.

So, if I make a very simple scene in ShowXpress containing just one fixture with the personality file LEDJ234_EventSpotRGBW(1ch), which you created for me last month, and click on STEPS and on the DMX logo, turning it from red to green, I am not able to make the fixture fade up from off to full on white.

The fixture is set for DMX address 1 and for 1 DMX channel. It works perfectly when controlled by a Universe-192 DMX Controller.

If I connect an oscilloscope to pins 1 or 2 on the DMX-out port of the fixture I see typical DMX data streaming (+/-5VDC RS485) from the Universe-192 DMX Controller. Reverting back to the DMX out from the Xpress-100 I see no DMX data. The data lines 1 and 2 remain at 0V.

Is the Xpress-100 faulty or am I doing something wrong in ShowXpress?

How can I test the Xpress-100 without using ShowXpress?

Best regards
Norman Garland
Garland Digital Ltd
UK.
NormanGarland
 
Posts: 3
Joined: 13 February 2021, 15:23

Re: Xpress-100 Windows 10 driver problem

Postby support » 08 March 2021, 16:12

If the welcome screen shows "1 Interface found Xpress100" and the data lines 1 and 2 remain at 0V, then your dmx interface is damaged.
Please return it for maintenance service.
The Lighting Controller
support
Administrateur
 
Posts: 9216
Joined: 07 December 2009, 16:32


Return to Cable

Who is online

Users browsing this forum: No registered users and 2 guests